Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 02, 2023 - 00:30 EST
Scheduled
Dear Customers,
In an effort to provide you continuing ongoing support and enhancements, we will be updating our Production environment on Thursday, March 2nd, 2023. The expected maintenance window is set between 12:30am EST to 09:30am EST. During the update the system may be in a degraded state, please refrain from making any critical changes to your system during the hours mentioned.
Thank you, Switch™ Tech Team
Posted Feb 28, 2023 - 11:21 EST
This scheduled maintenance affected: Management Portal and Access Rights Processing.