The issue with our backend services has been resolved.
Posted Aug 25, 2025 - 12:56 EDT
Monitoring
We have identified the issue and implemented a fix to our backend services. We will continue to monitor the system over the next week, thank you for your patience during this interruption.
Posted Aug 19, 2025 - 20:58 EDT
Investigating
The Switch™ Tech system is currently experiencing minor backend issues. This is resulting in issues with claiming credentials. If possible, please refrain from making any changes to your system at this time while we work to remedy the situation.