Switch Management Portal isn't loading underlying data

Incident Report for Switch™ Tech

Monitoring

A fix has been applied to the system and the management poral is loading data again. We are working through our test plan. We will have another update the morning of June 19, 2025.
Posted Jun 18, 2025 - 21:22 EDT

Update

We are continuing to investigate this issue.
Posted Jun 17, 2025 - 20:08 EDT

Update

We are continuing to investigate this issue.
Posted Jun 17, 2025 - 20:08 EDT

Investigating

We are currently investigating this issue.
Posted Jun 15, 2025 - 14:30 EDT
This incident affects: Management Portal.