A comprehensive fix for the issue with the Switch™ Tech credentials caused by a recent Android OS update is now available from the Google Play Store. We apologize for the inconvenience this has caused our users.
Thank you, Switch™ Tech Team
Posted Mar 15, 2023 - 14:08 EDT
Update
Yesterday we released a more comprehensive fix for the issue with The Switch™ Tech credentials caused by a recent Android OS update. It is now available from the Google Play Store. We will continue to monitor the situation for the next 24–48 hours. We apologize for the inconvenience this has caused our users.
Thank you, Switch™ Tech Team
Posted Mar 14, 2023 - 14:27 EDT
Monitoring
We have released a more comprehensive fix for the issue with The Switch™ Tech credentials caused by a recent Android OS update. It is now available from the Google Play Store and will improve backwards compatibility among other things. Please direct your Android phone users to download the latest version of the Switch™ Tech app from the Google Play Store. Please also advise your users that going forward, only Android OS versions 8 and higher will be supported in Switch™ Tech. We apologize for the inconvenience this has caused our users.
Thank you Switch™ Tech Team
Posted Mar 13, 2023 - 17:34 EDT
Update
We are continuing to work on the long term a fix for the issue with The Switch™ Tech credentials caused by a recent Android OS update. We anticipate pushing another release to the Google Play Store in the next few days to improve backwards compatibility. The new release will be compatible with Android versions greater than 8 (Oreo). We apologize for the inconvenience this has caused our users.
Thank you, Switch™ Tech Team
Posted Mar 13, 2023 - 13:49 EDT
Update
We have identified and are working on resolving an issue with The Switch™ Tech credentials caused by a recent Android OS update. We identified a user enabled change that will allow the mobile device to work again for a majority of users.
Go to the “App Info” in Settings. Select Switch Tap on “Permissions” Tap on “Nearby Devices” Tap on “Allow”
Some users may need to select the 3 dots in the top right corner of the app.
Go to the “App Permissions” in Settings. Select 3 dots in top right corner of app Select all permissions
We are continuing to work with the Google Play Store to address the situation in a timely fashion. Android OS versions 11, 12, 13 are the currently supported versions. Please advise your users that older OS versions are not supported. We apologize for the inconvenience this has caused our users.
Thank you, Switch™ Tech Team
Posted Mar 10, 2023 - 17:10 EST
Update
The Google Play Store is currently reviewing our submission to address the current credential. The recommendation is if you are prompted to update your Android device to wait a few days before doing so. Please advise your users accordingly. We apologize for the inconvenience this has caused our users.
Thank you, Switch™ Tech Team
Posted Mar 10, 2023 - 13:59 EST
Identified
We have identified and are working on resolving an issue with The Switch™ Tech credentials caused by a recent Android OS update. We identified a user enabled change that will allow the mobile device to work again in most cases.
Go to the “App Info” in Settings. Select Switch Tap on “Permissions” Tap on “Nearby Devices” Tap on “Allow”
We are continuing to work with the Google Play Store to address the situation in a timely fashion. The recommendation is if you are prompted to update your Android device to wait a few days before doing so. Please advise your users accordingly. We apologize for the inconvenience this has caused our users.
Thank you, Switch™ Tech Team
Posted Mar 10, 2023 - 12:10 EST
Investigating
We have identified and are working on resolving an issue with The Switch™ Tech credentials caused by a recent Android OS update. We are working with the Google Play Store to address the situation in a timely fashion. The recommendation is if you are prompted to update your Android device to wait a few days before doing so. Please advise your users accordingly. We apologize for the inconvenience this has caused our users.