A fix has been applied to the credential claiming processor. We are working through our test plan. We will have another update the morning of June 19, 2025.
Posted Jun 18, 2025 - 21:20 EDT
Update
We are continuing to work on a fix for this issue.
Posted Jun 17, 2025 - 21:48 EDT
Update
We are continuing to work on a fix for this issue.
Posted Jun 17, 2025 - 20:12 EDT
Update
We are continuing to work on a fix for this issue.
Posted Jun 17, 2025 - 20:03 EDT
Identified
We have identified the root problem between our credential data processing service and a system load balancer. We are working through updates in our test system to verify the solution.
Posted Jun 17, 2025 - 15:49 EDT
Update
We are continuing to investigate this issue.
Posted Jun 16, 2025 - 16:47 EDT
Investigating
The Switch™ Tech system is currently experiencing issues with our backend systems. This outage is currently impacting the ability for users to claim credentials. The issue has been identified and we are currently working on a solution. We apologize for any inconvenience during this time.